CVE-2019-8108 Magento Broken authentication and session managememt
An authenticated user can manipulate session validation settings in Magento, leading to insecure authentication and session management.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8108?
CVE-2019-8108 is a medium-severity authentication bypass vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can manipulate session validation setting for a storefront that leads to insecure authentication and session management.
Weakness: CWE-287
Which versions are affected by CVE-2019-8108?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8108?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-8108 being exploited?
There is no known exploitation of CVE-2019-8108 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-92ph-xm9v-cg3j.