CVE-2019-8109 Magento 2 Community Edition RCE Vulnerability via CSRF
An authenticated user can exploit a CSRF vulnerability in Magento to achieve arbitrary remote code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-8109?
CVE-2019-8109 is a high-severity vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can craft a malicious CSRF payload that can result in arbitrary command execution.
Weakness: CWE-352
Which versions are affected by CVE-2019-8109?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
Products include Magento Magento.
How do I fix CVE-2019-8109?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.
Is CVE-2019-8109 being exploited?
There is no known exploitation of CVE-2019-8109 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-x72m-p4qc-p7rv.