CVE-2019-8110 Magento 2 Community Edition RCE Vulnerability

High 8.8 Published Updated

Authenticated attackers can execute arbitrary code by manipulating email template hierarchies in Magento 2.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-8110?

CVE-2019-8110 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can leverage email templates hierarchy to manipulate the interceptor class in a way that allows an attacker to execute arbitrary code.

Which versions are affected by CVE-2019-8110?

4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.2.02.2.10
magento/community-edition PackagistFrom 2.2.02.2.10
magento/community-edition PackagistFrom 2.3.02.3.2-p1
magento/community-edition PackagistFrom 2.3.02.3.2-p1

Products include Magento Magento.

How do I fix CVE-2019-8110?

Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2019-8110 being exploited?

There is no known exploitation of CVE-2019-8110 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-gfcq-wh3g-c6h4.

Is CVE-2019-8110 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free