CVE-2019-8114 Magento 2 Community Edition RCE Vulnerability
Authenticated admin users can execute arbitrary code by uploading a crafted configuration archive file in Magento.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8114?
CVE-2019-8114 is a high-severity vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to import features can execute arbitrary code via crafted configuration archive file upload.
Weakness: CWE-434
Which versions are affected by CVE-2019-8114?
8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 1.9.4.3 |
magento/community-edition Packagist | All versions | 1.9.4.3 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
2 more packages
magento/project-community-edition Packagist | All versions | 1.9.4.3 |
magento/project-community-edition Packagist | All versions | 1.9.4.3 |
Products include Magento Magento.
How do I fix CVE-2019-8114?
Upgrade magento/community-edition to a fixed version for your release line: 1.9.4.3, 2.2.10 or 2.3.2-p2.
Is CVE-2019-8114 being exploited?
There is no known exploitation of CVE-2019-8114 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-crv7-r357-gw3w.