CVE-2019-8115 Magento 2 Community Edition XSS Vulnerability

Medium 4.8 Published Updated

An authenticated admin can inject arbitrary JavaScript via image uploads during product creation, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-8115?

CVE-2019-8115 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A reflected cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated admin user can inject arbitrary JavaScript code when adding an image for during simple product creation.

Weakness: CWE-79

Which versions are affected by CVE-2019-8115?

4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.2.02.2.10
magento/community-edition PackagistFrom 2.2.02.2.10
magento/community-edition PackagistFrom 2.3.02.3.2-p1
magento/community-edition PackagistFrom 2.3.02.3.2-p1

Products include Magento Magento.

How do I fix CVE-2019-8115?

Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-8115 being exploited?

There is no known exploitation of CVE-2019-8115 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-29mr-gr4c-vf9c.

Is CVE-2019-8115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free