CVE-2019-8117 Magento 2 Community Edition XSS Vulnerability

Medium 5.4 Published Updated

An authenticated user can inject arbitrary JavaScript via product view IDs, enabling session hijacking or malicious actions in Magento.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-8117?

CVE-2019-8117 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticates user can inject arbitrary JavaScript code via product view id specification.

Weakness: CWE-79

Which versions are affected by CVE-2019-8117?

4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.2.02.2.10
magento/community-edition PackagistFrom 2.2.02.2.10
magento/community-edition PackagistFrom 2.3.02.3.2-p1
magento/community-edition PackagistFrom 2.3.02.3.2-p1

Products include Magento Magento.

How do I fix CVE-2019-8117?

Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-8117 being exploited?

There is no known exploitation of CVE-2019-8117 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-v99w-jxr4-w6mc.

Is CVE-2019-8117 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free