CVE-2019-8118 Magento 2 Community Edition Weak Cryptography
Attackers can potentially read stored failed login attempt data due to weak cryptographic storage in Magento customer accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8118?
CVE-2019-8118 is a medium-severity vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 uses weak cryptographic function to store the failed login attempts for customer accounts.
Weakness: CWE-312
Which versions are affected by CVE-2019-8118?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
Products include Magento Magento.
How do I fix CVE-2019-8118?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.19, 2.2.10 or 2.3.3.
Is CVE-2019-8118 being exploited?
There is no known exploitation of CVE-2019-8118 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-hmch-9947-82rj.