CVE-2019-8119 Magento 2 Community Edition RCE Vulnerability
Authenticated admin users can achieve remote code execution by injecting code into XSLT files during bulk product imports.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8119?
CVE-2019-8119 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated admin user with import product privileges can delete files through bulk product import and inject code into XSLT file. The combination of these manipulations can lead to remote code execution.
Which versions are affected by CVE-2019-8119?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
Products include Magento Magento.
How do I fix CVE-2019-8119?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.19, 2.2.10 or 2.3.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-8119 being exploited?
There is no known exploitation of CVE-2019-8119 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-j63v-wcf9-c9hm.