# CVE-2019-8120: Magento 2 Community Edition XSS Vulnerability

> Authenticated users can inject arbitrary JavaScript via email address fields, potentially leading to session hijacking or malicious actions on behalf of other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-985w-mqqp-7287

## What is CVE-2019-8120?

CVE-2019-8120 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user can inject arbitrary Javascript code by manipulating section of a POST request related to customer's email address.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-8120?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.19 |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.19 |
| `magento/community-edition` | Packagist | From 2.2.0 | 2.2.10 |
| `magento/community-edition` | Packagist | From 2.2.0 | 2.2.10 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.3 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.3 |

Products: Magento Magento.

## How do I fix CVE-2019-8120?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.19, 2.2.10 or 2.3.3.

## Is CVE-2019-8120 being exploited?

There is no known exploitation of CVE-2019-8120 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8120 and fix it if it is affected.

What it is: CVE-2019-8120 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-8120 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.19
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.19
- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.10
- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.10
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.3
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8120/ (Markdown: https://insights.sbomify.com/CVE-2019-8120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8120
- OSV: https://osv.dev/vulnerability/CVE-2019-8120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8120/
Summaries are generated and may contain mistakes; the official description above is the record.
