CVE-2019-8121 Using JS libraries with known security vulnerabilities
Attackers can exploit known vulnerabilities in outdated JavaScript libraries bundled with Magento to compromise the application.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8121?
CVE-2019-8121 is a critical vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An insecure component vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Magento 2 codebase leveraged outdated versions of JS libraries (Bootstrap, jquery, Knockout) with known security vulnerabilities.
Which versions are affected by CVE-2019-8121?
8 open source packages ship an affected version, including magento/community-edition and magento/product-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.3 |
magento/community-edition Packagist | From 2.3 | 2.3.3 |
magento/product-community-edition Packagist | From 2.2 | 2.2.10 |
magento/product-community-edition Packagist | From 2.2 | 2.2.10 |
2 more packages
magento/product-community-edition Packagist | From 2.3 | 2.3.2-p2 |
magento/product-community-edition Packagist | From 2.3 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8121?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.3.
Is CVE-2019-8121 being exploited?
There is no known exploitation of CVE-2019-8121 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-89ch-hqf9-rgp3.