CVE-2019-8123 Magento 2 Community Edition Insufficient Logging
Insufficient logging in Magento prevents effective tracking of configuration changes, potentially hiding unauthorized modifications from administrators.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8123?
CVE-2019-8123 is a medium-severity vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes.
Which versions are affected by CVE-2019-8123?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
Products include Magento Magento.
How do I fix CVE-2019-8123?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.19, 2.2.10 or 2.3.3.
Is CVE-2019-8123 being exploited?
There is no known exploitation of CVE-2019-8123 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-fp5m-4mqh-849p.