CVE-2019-8124 Magento 2 Community Edition Insufficient Logging
Insufficient logging of admin design configuration actions in Magento allows attackers to perform repudiation attacks, hindering audit trails.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8124?
CVE-2019-8124 is a medium-severity vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An insufficient logging and monitoring vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Failure to track admin actions related to design configuration could lead to repudiation attacks.
Which versions are affected by CVE-2019-8124?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
Products include Magento Magento.
How do I fix CVE-2019-8124?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.19, 2.2.10 or 2.3.3.
Is CVE-2019-8124 being exploited?
There is no known exploitation of CVE-2019-8124 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-x5q5-6wvf-2fpq.