CVE-2019-8133 Bypass of sitemp access restrictions
Privileged users can bypass directory restrictions to overwrite configuration files, potentially causing denial of service in Magento.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8133?
CVE-2019-8133 is a medium-severity vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A security bypass vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. A user with privileges to generate sitemaps can bypass configuration that restricts directory access. The bypass allows overwrite of a subset of configuration files which can lead to denial of service.
Which versions are affected by CVE-2019-8133?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8133?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Is CVE-2019-8133 being exploited?
There is no known exploitation of CVE-2019-8133 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-62fx-3v4f-mwxm.