CVE-2019-8135 Remote code execution via vulnerable Symphony dependecy injection
Attackers can achieve remote code execution in Magento by exploiting dependency injection flaws in the Symfony framework via user-controlled data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8135?
CVE-2019-8135 is a critical code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Dependency injection through Symphony framework allows service identifiers to be derived from user controlled data, which can lead to remote code execution.
Weakness: CWE-74
Which versions are affected by CVE-2019-8135?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8135?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-8135 being exploited?
There is no known exploitation of CVE-2019-8135 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-3q5x-7mxp-rp6j.