# CVE-2019-8135: Remote code execution via vulnerable Symphony dependecy injection

> Attackers can achieve remote code execution in Magento by exploiting dependency injection flaws in the Symfony framework via user-controlled data.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3q5x-7mxp-rp6j

## What is CVE-2019-8135?

CVE-2019-8135 is a critical code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Dependency injection through Symphony framework allows service identifiers to be derived from user controlled data, which can lead to remote code execution.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2019-8135?

4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | From 2.2 | 2.2.10 |
| `magento/community-edition` | Packagist | From 2.2 | 2.2.10 |
| `magento/community-edition` | Packagist | From 2.3 | 2.3.2-p2 |
| `magento/community-edition` | Packagist | From 2.3 | 2.3.2-p2 |

Products: Magento Magento.

## How do I fix CVE-2019-8135?

Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.

## Is CVE-2019-8135 being exploited?

There is no known exploitation of CVE-2019-8135 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8135 and fix it if it is affected.

What it is: CVE-2019-8135 is a critical code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-8135 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 2.2; fixed in 2.2.10
- magento/community-edition (Packagist): affected from 2.2; fixed in 2.2.10
- magento/community-edition (Packagist): affected from 2.3; fixed in 2.3.2-p2
- magento/community-edition (Packagist): affected from 2.3; fixed in 2.3.2-p2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8135/ (Markdown: https://insights.sbomify.com/CVE-2019-8135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8135
- OSV: https://osv.dev/vulnerability/CVE-2019-8135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8135/
Summaries are generated and may contain mistakes; the official description above is the record.
