CVE-2019-8136 Magento 2 Community Edition Insecure Component
Magento 2 uses outdated Symfony HTTP components, requiring an upgrade to mitigate potential risks associated with the insecure dependency.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8136?
CVE-2019-8136 is a critical vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An insecure component vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Magento 2 codebase leveraged outdated versions of HTTP specification abstraction implemented in symphony component.
Which versions are affected by CVE-2019-8136?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
Products include Magento Magento.
How do I fix CVE-2019-8136?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.
Is CVE-2019-8136 being exploited?
There is no known exploitation of CVE-2019-8136 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-xgcp-59g2-wm8g.