{"answers":{"affected":"4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-8136 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.","what":"CVE-2019-8136 is a critical vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-8136 and fix it if it is affected.\n\nWhat it is: CVE-2019-8136 is a critical vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-8136 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.10\n- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.10\n- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.2-p1\n- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.2-p1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-8136/ (Markdown: https://insights.sbomify.com/CVE-2019-8136/index.md)","id":"CVE-2019-8136","markdown":"https://insights.sbomify.com/CVE-2019-8136/index.md","name":"CVE-2019-8136","record":{"aliases":["GHSA-xgcp-59g2-wm8g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"none","summary":"Magento 2 uses outdated Symfony HTTP components, requiring an upgrade to mitigate potential risks associated with the insecure dependency.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"An insecure component vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Magento 2 codebase leveraged outdated versions of HTTP specification abstraction implemented in symphony component.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento 2 Community Edition Insecure Component","id":"CVE-2019-8136","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"magento:magento","products":["magento:magento"],"type":"supply_chain","year":"2019"},"n_packages":4,"n_references":1,"next":{"headline":"Magento 2 Community Edition RCE Vulnerability","id":"CVE-2019-8137"},"packages":[{"ecosystem":"Packagist","fixed":["2.2.10"],"introduced":["2.2.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-xgcp-59g2-wm8g"},{"ecosystem":"Packagist","fixed":["2.2.10"],"introduced":["2.2.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-xgcp-59g2-wm8g"},{"ecosystem":"Packagist","fixed":["2.3.2-p1"],"introduced":["2.3.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-xgcp-59g2-wm8g"},{"ecosystem":"Packagist","fixed":["2.3.2-p1"],"introduced":["2.3.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-xgcp-59g2-wm8g"}],"prev":{"headline":"Remote code execution via vulnerable Symphony dependecy injection","id":"CVE-2019-8135"},"products":["Magento 2"],"published":"2019-11-05","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Adobe Systems Incorporated"]},"summary":"Magento 2 uses outdated Symfony HTTP components, requiring an upgrade to mitigate potential risks associated with the insecure dependency.","url":"https://insights.sbomify.com/CVE-2019-8136/"}