CVE-2019-8141 Magento 2 Community Edition RCE Vulnerability
An authenticated admin can execute arbitrary code via Phar deserialization in the import functionality of Magento.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8141?
CVE-2019-8141 is a high-severity unsafe deserialization vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with administrative privileges (system level import) can execute arbitrary code through a Phar deserialization vulnerability in the import functionality.
Weakness: CWE-502
Which versions are affected by CVE-2019-8141?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.1.0 | 2.1.19 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
magento/community-edition Packagist | From 2.3.0 | 2.3.3 |
Products include Magento Magento.
How do I fix CVE-2019-8141?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.19, 2.2.10 or 2.3.3.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2019-8141 being exploited?
There is no known exploitation of CVE-2019-8141 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-9wr9-fw9v-8fgr.