CVE-2019-8143 Magento Injection vulnerability via email templates
Authenticated users with email template access can execute SQL queries to read sensitive database information in Magento.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8143?
CVE-2019-8143 is a medium-severity SQL injection vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to email templates can send malicious SQL queries and obtain access to sensitive information stored in the database.
Weakness: CWE-89
Which versions are affected by CVE-2019-8143?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p1 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p1 |
Products include Magento Magento.
How do I fix CVE-2019-8143?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2019-8143 being exploited?
There is no known exploitation of CVE-2019-8143 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-94q8-gx29-6mqv.