CVE-2019-8145 Magento Cross-Site Scripting via Attribute Set Name
Authenticated users can inject arbitrary JavaScript into attribute set names, potentially leading to session hijacking or malicious actions in Magento.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-8145?
CVE-2019-8145 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 6 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can inject arbitrary JavaScript code into the attribute set name when listing the products.
Weakness: CWE-79
Which versions are affected by CVE-2019-8145?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p1 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p1 |
Products include Magento Magento.
How do I fix CVE-2019-8145?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-8145 being exploited?
There is no known exploitation of CVE-2019-8145 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-xv69-f7x5-r4qw.