CVE-2019-8149 Magento Broken authentication and session managememt
An unauthenticated attacker can hijack sessions by appending arbitrary session IDs that remain valid after authentication, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8149?
CVE-2019-8149 is a critical authentication bypass vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An unauthenticated user can append arbitrary session id that will not be invalidated by subsequent authentication.
Weakness: CWE-613
Which versions are affected by CVE-2019-8149?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p1 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p1 |
Products include Magento Magento.
How do I fix CVE-2019-8149?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-8149 being exploited?
There is no known exploitation of CVE-2019-8149 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-8mwx-wpp4-5xh4.