CVE-2019-8150 Magento 2 Community Edition RCE Vulnerability
Authenticated users with layout privileges can inject malicious code into page layouts, leading to remote code execution on Magento installations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8150?
CVE-2019-8150 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to manipulate layouts and images can insert a malicious payload into the page layout.
Which versions are affected by CVE-2019-8150?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8150?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-8150 being exploited?
There is no known exploitation of CVE-2019-8150 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-p783-gj6m-9r88.