CVE-2019-8151 Magento Server-Side Request Forgery (SSRF)
An authenticated admin can execute arbitrary code via SSRF in Magento due to unsafe carrier gateway handling.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8151?
CVE-2019-8151 is a high-severity server-side request forgery vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to manipulate shippment settings can execute arbitrary code through server-side request forgery due to unsafe handling of a carrier gateway.
Weakness: CWE-918
Which versions are affected by CVE-2019-8151?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8151?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2019-8151 being exploited?
There is no known exploitation of CVE-2019-8151 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-f73h-224c-62qr.