CVE-2019-8152 Magento 2 Community Edition XSS Vulnerability
Authenticated users can inject malicious JavaScript into the admin dashboard cache via the WYSIWYG editor, potentially leading to session hijacking or further compromise.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-8152?
CVE-2019-8152 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.
Weakness: CWE-79
Which versions are affected by CVE-2019-8152?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8152?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-8152 being exploited?
There is no known exploitation of CVE-2019-8152 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-jjmg-xmq2-g6ff.