CVE-2019-8153 Magento Cross-site Scripting (XSS)
Attackers can bypass URL escaping to execute malicious cross-site scripting payloads in Magento, requiring an upgrade to secure versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-8153?
CVE-2019-8153 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 5 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A mitigation bypass to prevent cross-site scripting (XSS) exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Successful exploitation of this vulnerability would result in an attacker being able to bypass the `escapeURL()` function and execute a malicious XSS payload.
Weakness: CWE-79
Which versions are affected by CVE-2019-8153?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8153?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-8153 being exploited?
There is no known exploitation of CVE-2019-8153 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-273r-v888-vgc6.