CVE-2019-8154 Magento remote code execution vulnerability
Authenticated users with catalog privileges can execute arbitrary code via crafted XML files in Magento 2.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8154?
CVE-2019-8154 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to modify product catalogs can trigger PHP file inclusion through a crafted XML file that specifies product design update.
Weakness: CWE-829
Which versions are affected by CVE-2019-8154?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8154?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-8154 being exploited?
There is no known exploitation of CVE-2019-8154 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-4v2q-hjx3-c4vr.