CVE-2019-8156 Magento 2 Community Edition SSRF vulnerability
An authenticated admin can exploit an SSRF vulnerability in Magento to achieve remote code execution by manipulating connector API endpoints.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8156?
CVE-2019-8156 is a high-severity server-side request forgery vulnerability in Magento Magento, published on 6 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A server-side request forgery (SSRF) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to modify store configurations can manipulate the connector api endpoint to enable remote code execution.
Weakness: CWE-918
Which versions are affected by CVE-2019-8156?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8156?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2019-8156 being exploited?
There is no known exploitation of CVE-2019-8156 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-775w-gx3f-4j4f.