CVE-2019-8158 Magento 2 Community Edition XML Injection
An attacker can exploit an XPath entity injection in Magento's page cache module to access underlying XML data via crafted GET requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8158?
CVE-2019-8158 is a critical vulnerability in Magento Magento, published on 6 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An XPath entity injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An attacker can craft a GET request to page cache block rendering module that gets passed to XML data processing engine without validation. The crafted key/value GET request data allows an attacker to limited access to underlying XML data.
Weakness: CWE-91
Which versions are affected by CVE-2019-8158?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8158?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Is CVE-2019-8158 being exploited?
There is no known exploitation of CVE-2019-8158 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-8p5c-f836-m4h7.