CVE-2019-8159 Magento 2 Community Edition RCE Vulnerability
Authenticated users with system privileges can execute arbitrary code via OS command injection in Magento.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8159?
CVE-2019-8159 is a high-severity command injection vulnerability in Magento Magento, published on 6 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with system data manipulation privileges can execute aribitrary code through arbitrary file deletion and OS command injection.
Weakness: CWE-78
Which versions are affected by CVE-2019-8159?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.2 | 2.2.10 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
magento/community-edition Packagist | From 2.3 | 2.3.2-p2 |
Products include Magento Magento.
How do I fix CVE-2019-8159?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p2.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2019-8159 being exploited?
There is no known exploitation of CVE-2019-8159 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-47h6-hfpv-7phj.