{"answers":{"affected":"2 open source packages ship an affected version, including magento/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-8227 in the wild and no public exploit code.","fix":"Upgrade magento/core to 1.9.4.3 or later.","what":"CVE-2019-8227 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 6 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-8227 and fix it if it is affected.\n\nWhat it is: CVE-2019-8227 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 6 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-8227 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/core (Packagist): affected all versions; fixed in 1.9.4.3\n- magento/core (Packagist): affected all versions; fixed in 1.9.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-8227/ (Markdown: https://insights.sbomify.com/CVE-2019-8227/index.md)","id":"CVE-2019-8227","markdown":"https://insights.sbomify.com/CVE-2019-8227/index.md","name":"CVE-2019-8227","record":{"aliases":["GHSA-j49x-jjmj-9fqj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"high_privilege","summary":"Authenticated users with limited admin privileges can inject arbitrary JavaScript via import/export profile actions in Magento.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Magento prior to 1.9.4.3 and Magento prior to 1.14.4.3, an authenticated user with limited administrative privileges can inject arbitrary JavaScript code via import / export functionality when creating profile action XML.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento XSS Vulnerability","id":"CVE-2019-8227","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"magento:magento","products":["magento:magento"],"type":"xss","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in Magento 1","id":"CVE-2019-8228"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.4.3"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":null,"source":"GHSA-j49x-jjmj-9fqj"},{"ecosystem":"Packagist","fixed":["1.9.4.3"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":"pkg:composer/magento/core","source":"GHSA-j49x-jjmj-9fqj"}],"prev":{"headline":"Security feature bypass in Adobe Acrobat and Reader","id":"CVE-2019-8226"},"products":["Magento 1"],"published":"2019-11-06","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Adobe Systems Incorporated"]},"summary":"Authenticated users with limited admin privileges can inject arbitrary JavaScript via import/export profile actions in Magento.","url":"https://insights.sbomify.com/CVE-2019-8227/"}