{"answers":{"affected":"2 open source packages ship an affected version, including magento/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-8231 in the wild and no public exploit code.","fix":"Upgrade magento/core to 1.9.4.3 or later.","what":"CVE-2019-8231 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-8231 and fix it if it is affected.\n\nWhat it is: CVE-2019-8231 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-8231 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/core (Packagist): affected all versions; fixed in 1.9.4.3\n- magento/core (Packagist): affected all versions; fixed in 1.9.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-8231/ (Markdown: https://insights.sbomify.com/CVE-2019-8231/index.md)","id":"CVE-2019-8231","markdown":"https://insights.sbomify.com/CVE-2019-8231/index.md","name":"CVE-2019-8231","record":{"aliases":["GHSA-qpc8-m2xm-9w75"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"high_privilege","summary":"Authenticated administrators can execute arbitrary code via custom layout modifications in Magento, requiring an upgrade to secure the platform.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"In Magento to 1.9.4.3 and Magento prior to 1.14.4.3, an authenticated user with administrative privileges for editing attribute sets can execute arbitrary code through custom layout modification.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento Remote code execution through catalog attribute sets","id":"CVE-2019-8231","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"magento:magento","products":["magento:magento"],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Magento 2 Community Edition RCE Vulnerability","id":"CVE-2019-8232"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.4.3"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":null,"source":"GHSA-qpc8-m2xm-9w75"},{"ecosystem":"Packagist","fixed":["1.9.4.3"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":"pkg:composer/magento/core","source":"GHSA-qpc8-m2xm-9w75"}],"prev":{"headline":"Magento Remote code execution through support/output path modification","id":"CVE-2019-8230"},"products":["Magento 1"],"published":"2019-11-05","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Adobe Systems Incorporated"]},"summary":"Authenticated administrators can execute arbitrary code via custom layout modifications in Magento, requiring an upgrade to secure the platform.","url":"https://insights.sbomify.com/CVE-2019-8231/"}