# CVE-2019-8231: Magento Remote code execution through catalog attribute sets

> Authenticated administrators can execute arbitrary code via custom layout modifications in Magento, requiring an upgrade to secure the platform.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qpc8-m2xm-9w75

## What is CVE-2019-8231?

CVE-2019-8231 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Magento to 1.9.4.3 and Magento prior to 1.14.4.3, an authenticated user with administrative privileges for editing attribute sets can execute arbitrary code through custom layout modification.

## Which versions are affected by CVE-2019-8231?

2 open source packages ship an affected version, including magento/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/core` | Packagist | All versions | 1.9.4.3 |
| `magento/core` | Packagist | All versions | 1.9.4.3 |

Products: Magento Magento.

## How do I fix CVE-2019-8231?

Upgrade magento/core to 1.9.4.3 or later.

## Is CVE-2019-8231 being exploited?

There is no known exploitation of CVE-2019-8231 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8231 and fix it if it is affected.

What it is: CVE-2019-8231 is a high-severity code injection vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-8231 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/core (Packagist): affected all versions; fixed in 1.9.4.3
- magento/core (Packagist): affected all versions; fixed in 1.9.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8231/ (Markdown: https://insights.sbomify.com/CVE-2019-8231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8231
- OSV: https://osv.dev/vulnerability/CVE-2019-8231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8231/
Summaries are generated and may contain mistakes; the official description above is the record.
