CVE-2019-8232 Magento 2 Community Edition RCE Vulnerability
An authenticated admin can execute arbitrary code via a race condition modifying webserver configuration files in Magento.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8232?
CVE-2019-8232 is a medium-severity vulnerability in Magento Magento, published on 5 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.
Weakness: CWE-362
Which versions are affected by CVE-2019-8232?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
Products include Magento Magento.
How do I fix CVE-2019-8232?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.
Is CVE-2019-8232 being exploited?
There is no known exploitation of CVE-2019-8232 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-6vc8-3xf2-qrxx.