{"answers":{"affected":"4 open source packages ship an affected version, including rubygems-update. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-8320 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to a fixed version for your release line: 2.7.9 or 3.0.3.","what":"CVE-2019-8320 is a high-severity path traversal vulnerability in n/a, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-8320 and fix it if it is affected.\n\nWhat it is: CVE-2019-8320 is a high-severity path traversal vulnerability in n/a, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-8320 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected from 2.7.6; fixed in 2.7.9\n- rubygems-update (RubyGems): affected from 2.7.6; fixed in 2.7.9\n- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.3\n- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-8320/ (Markdown: https://insights.sbomify.com/CVE-2019-8320/index.md)","id":"CVE-2019-8320","markdown":"https://insights.sbomify.com/CVE-2019-8320/index.md","name":"CVE-2019-8320","record":{"aliases":["ALPINE-CVE-2019-8320","DEBIAN-CVE-2019-8320","GHSA-5x32-c9mf-49cc","UBUNTU-CVE-2019-8320"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"A malicious gem can delete arbitrary files on the user's machine via directory traversal, potentially causing data loss or system instability.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Delete directory using symlink when decompressing tar","id":"CVE-2019-8320","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":4,"n_references":5,"next":{"headline":"RubyGems Escape sequence injection vulnerability in verbose","id":"CVE-2019-8321"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.9"],"introduced":["2.7.6"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-5x32-c9mf-49cc"},{"ecosystem":"RubyGems","fixed":["2.7.9"],"introduced":["2.7.6"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-5x32-c9mf-49cc"},{"ecosystem":"RubyGems","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-5x32-c9mf-49cc"},{"ecosystem":"RubyGems","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-5x32-c9mf-49cc"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2019-8319"},"products":["n/a"],"published":"2019-06-06","related":[{"cvss_score":8.3,"headline":"RubyGems allows creation of users with arbitrary unverified emails","id":"CVE-2022-36073","kev_date_added":null,"published":"2022-09-07"},{"cvss_score":7.8,"headline":"RubyGems Deserialization of Untrusted Data vulnerability","id":"CVE-2018-1000074","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.5,"headline":"RubyGems Link Following vulnerability","id":"CVE-2018-1000073","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":5.8,"headline":"RubyGems HTTPS to HTTP redirect","id":"CVE-2012-2125","kev_date_added":null,"published":"2013-10-01"},{"cvss_score":5.5,"headline":"RubyGems Path Traversal vulnerability","id":"CVE-2018-1000079","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":4.3,"headline":"RubyGems does not verify SSL certificate","id":"CVE-2012-2126","kev_date_added":null,"published":"2013-10-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A malicious gem can delete arbitrary files on the user's machine via directory traversal, potentially causing data loss or system instability.","url":"https://insights.sbomify.com/CVE-2019-8320/"}