# CVE-2019-8320: RubyGems Delete directory using symlink when decompressing tar

> A malicious gem can delete arbitrary files on the user's machine via directory traversal, potentially causing data loss or system instability.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-8320, DEBIAN-CVE-2019-8320, GHSA-5x32-c9mf-49cc, UBUNTU-CVE-2019-8320

## What is CVE-2019-8320?

CVE-2019-8320 is a high-severity path traversal vulnerability in n/a, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-8320?

4 open source packages ship an affected version, including rubygems-update. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubygems-update` | RubyGems | From 2.7.6 | 2.7.9 |
| `rubygems-update` | RubyGems | From 2.7.6 | 2.7.9 |
| `rubygems-update` | RubyGems | From 3.0.0 | 3.0.3 |
| `rubygems-update` | RubyGems | From 3.0.0 | 3.0.3 |

Products: Rubygems Rubygems.

## How do I fix CVE-2019-8320?

Upgrade rubygems-update to a fixed version for your release line: 2.7.9 or 3.0.3.

## Is CVE-2019-8320 being exploited?

There is no known exploitation of CVE-2019-8320 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36073](https://insights.sbomify.com/CVE-2022-36073/): RubyGems allows creation of users with arbitrary unverified emails (high 8.3)
- [CVE-2018-1000074](https://insights.sbomify.com/CVE-2018-1000074/): RubyGems Deserialization of Untrusted Data vulnerability (high 7.8)
- [CVE-2018-1000073](https://insights.sbomify.com/CVE-2018-1000073/): RubyGems Link Following vulnerability (high 7.5)
- [CVE-2012-2125](https://insights.sbomify.com/CVE-2012-2125/): RubyGems HTTPS to HTTP redirect (medium 5.8)
- [CVE-2018-1000079](https://insights.sbomify.com/CVE-2018-1000079/): RubyGems Path Traversal vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8320 and fix it if it is affected.

What it is: CVE-2019-8320 is a high-severity path traversal vulnerability in n/a, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-8320 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubygems-update (RubyGems): affected from 2.7.6; fixed in 2.7.9
- rubygems-update (RubyGems): affected from 2.7.6; fixed in 2.7.9
- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.3
- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8320/ (Markdown: https://insights.sbomify.com/CVE-2019-8320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8320
- OSV: https://osv.dev/vulnerability/CVE-2019-8320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8320/
Summaries are generated and may contain mistakes; the official description above is the record.
