CVE-2019-8321 RubyGems Escape sequence injection vulnerability in verbose
Attackers can inject escape sequences via verbose output in RubyGems, potentially manipulating terminal display or logs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8321?
CVE-2019-8321 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.
Weakness: CWE-88
Which versions are affected by CVE-2019-8321?
4 open source packages ship an affected version, including rubygems-update. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
rubygems-update RubyGems | From 2.6.0 | 2.7.9 |
rubygems-update RubyGems | From 2.6.0 | 2.7.9 |
rubygems-update RubyGems | From 3.0.0 | 3.0.2 |
rubygems-update RubyGems | From 3.0.0 | 3.0.2 |
Products include Debian Debian Linux, Opensuse Leap, Rubygems Rubygems.
How do I fix CVE-2019-8321?
Upgrade rubygems-update to a fixed version for your release line: 2.7.9 or 3.0.2.
Is CVE-2019-8321 being exploited?
There is no known exploitation of CVE-2019-8321 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2019-8321, DEBIAN-CVE-2019-8321, GHSA-fr32-gr5c-xq5c, UBUNTU-CVE-2019-8321.