{"answers":{"affected":"4 open source packages ship an affected version, including rubygems-update. It affects 3 products.","exploited":"There is no known exploitation of CVE-2019-8321 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to a fixed version for your release line: 2.7.9 or 3.0.2.","what":"CVE-2019-8321 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-8321 and fix it if it is affected.\n\nWhat it is: CVE-2019-8321 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-8321 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected from 2.6.0; fixed in 2.7.9\n- rubygems-update (RubyGems): affected from 2.6.0; fixed in 2.7.9\n- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.2\n- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-8321/ (Markdown: https://insights.sbomify.com/CVE-2019-8321/index.md)","id":"CVE-2019-8321","markdown":"https://insights.sbomify.com/CVE-2019-8321/index.md","name":"CVE-2019-8321","record":{"aliases":["ALPINE-CVE-2019-8321","DEBIAN-CVE-2019-8321","GHSA-fr32-gr5c-xq5c","UBUNTU-CVE-2019-8321"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Attackers can inject escape sequences via verbose output in RubyGems, potentially manipulating terminal display or logs.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"leap","vendor":"opensuse"},{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Escape sequence injection vulnerability in verbose","id":"CVE-2019-8321","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","opensuse:leap"],"type":"other","year":"2019"},"n_packages":4,"n_references":3,"next":{"headline":"RubyGems Escape sequence injection vulnerability in gem owner","id":"CVE-2019-8322"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.9"],"introduced":["2.6.0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-fr32-gr5c-xq5c"},{"ecosystem":"RubyGems","fixed":["2.7.9"],"introduced":["2.6.0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-fr32-gr5c-xq5c"},{"ecosystem":"RubyGems","fixed":["3.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-fr32-gr5c-xq5c"},{"ecosystem":"RubyGems","fixed":["3.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-fr32-gr5c-xq5c"}],"prev":{"headline":"RubyGems Delete directory using symlink when decompressing tar","id":"CVE-2019-8320"},"products":["n/a"],"published":"2019-06-17","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can inject escape sequences via verbose output in RubyGems, potentially manipulating terminal display or logs.","url":"https://insights.sbomify.com/CVE-2019-8321/"}