CVE-2019-8322 RubyGems Escape sequence injection vulnerability in gem owner
Attackers can inject escape sequences via crafted API responses in the gem owner command, potentially manipulating terminal output.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8322?
CVE-2019-8322 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 17 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.
Weakness: CWE-74
Which versions are affected by CVE-2019-8322?
4 open source packages ship an affected version, including rubygems-update. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
rubygems-update RubyGems | From 2.6.0 | 2.7.9 |
rubygems-update RubyGems | From 2.6.0 | 2.7.9 |
rubygems-update RubyGems | From 3.0.0 | 3.0.2 |
rubygems-update RubyGems | From 3.0.0 | 3.0.2 |
Products include Debian Debian Linux, Opensuse Leap, Rubygems Rubygems.
How do I fix CVE-2019-8322?
Upgrade rubygems-update to a fixed version for your release line: 2.7.9 or 3.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-8322 being exploited?
There is no known exploitation of CVE-2019-8322 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2019-8322, DEBIAN-CVE-2019-8322, GHSA-mh37-8c3g-3fgc, UBUNTU-CVE-2019-8322.