# CVE-2019-8323: RubyGems Escape sequence injection vulnerability in api response handling

> Attackers can inject escape sequences into terminal output via malicious API responses in RubyGems, potentially affecting user terminals.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-8323, DEBIAN-CVE-2019-8323, GHSA-3h4r-pjv6-cph9, UBUNTU-CVE-2019-8323

## What is CVE-2019-8323?

CVE-2019-8323 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2019-8323?

4 open source packages ship an affected version, including rubygems-update. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubygems-update` | RubyGems | From 2.6.0 | 2.7.9 |
| `rubygems-update` | RubyGems | From 2.6.0 | 2.7.9 |
| `rubygems-update` | RubyGems | From 3.0.0 | 3.0.2 |
| `rubygems-update` | RubyGems | From 3.0.0 | 3.0.2 |

Products: Debian Debian Linux, Opensuse Leap, Rubygems Rubygems.

## How do I fix CVE-2019-8323?

Upgrade rubygems-update to a fixed version for your release line: 2.7.9 or 3.0.2.

## Is CVE-2019-8323 being exploited?

There is no known exploitation of CVE-2019-8323 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8323 and fix it if it is affected.

What it is: CVE-2019-8323 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-8323 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubygems-update (RubyGems): affected from 2.6.0; fixed in 2.7.9
- rubygems-update (RubyGems): affected from 2.6.0; fixed in 2.7.9
- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.2
- rubygems-update (RubyGems): affected from 3.0.0; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8323/ (Markdown: https://insights.sbomify.com/CVE-2019-8323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8323
- OSV: https://osv.dev/vulnerability/CVE-2019-8323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8323/
Summaries are generated and may contain mistakes; the official description above is the record.
