# CVE-2019-8331: Bootstrap Vulnerable to Cross-Site Scripting

> Cross-site scripting vulnerability in Bootstrap allows attackers to execute arbitrary scripts via malicious tooltip or popover data-template attributes.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2019
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-105101, AZL-105137, AZL-105155, AZL-105203, AZL-105266, CLSA-2026-1774743842, CLSA-2026-1782435540, DEBIAN-CVE-2019-8331, GHSA-9v3m-8fp8-mj99, RHSA-2022:8848, RHSA-2022:8865, ROOT-APP-NPM-CVE-2019-8331, UBUNTU-CVE-2019-8331

## What is CVE-2019-8331?

CVE-2019-8331 is a medium-severity cross-site scripting vulnerability in F5 Big-Ip Access Policy Manager, published on 20 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-8331?

28 open source packages ship an affected version, including bootstrap, org.webjars:bootstrap and Bootstrap.Less. It affects 16 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bootstrap` | NuGet | From 3.0.0 | 3.4.1 |
| `bootstrap` | NuGet | From 3.0.0 | 3.4.1 |
| `bootstrap` | NuGet | From 4.0.0 | 4.3.1 |
| `bootstrap` | NuGet | From 4.0.0 | 4.3.1 |
| `bootstrap` | RubyGems | All versions | 4.3.1 |
| `bootstrap` | RubyGems | All versions | 4.3.1 |
| `bootstrap` | npm | From 3.0.0 | 3.4.1 |
| `bootstrap` | npm | From 3.0.0 | 3.4.1 |
| `bootstrap` | npm | From 4.0.0 | 4.3.1 |
| `bootstrap` | npm | From 4.0.0 | 4.3.1 |
| `org.webjars:bootstrap` | Maven | From 3.0.0 | 3.4.1 |
| `org.webjars:bootstrap` | Maven | From 3.0.0 | 3.4.1 |
| `org.webjars:bootstrap` | Maven | From 4.0.0 | 4.3.1 |
| `org.webjars:bootstrap` | Maven | From 4.0.0 | 4.3.1 |
| `Bootstrap.Less` | NuGet | From 3.0.0 | 3.4.1 |
| `Bootstrap.Less` | NuGet | From 3.0.0 | 3.4.1 |
| `bootstrap.sass` | NuGet | All versions | 4.3.1 |
| `bootstrap.sass` | NuGet | All versions | 4.3.1 |
| `twbs/bootstrap` | Packagist | From 3.0.0 | 3.4.1 |
| `twbs/bootstrap` | Packagist | From 3.0.0 | 3.4.1 |
| `twbs/bootstrap` | Packagist | From 4.0.0 | 4.3.1 |
| `twbs/bootstrap` | Packagist | From 4.0.0 | 4.3.1 |
| `bootstrap-sass` | RubyGems | From 3.0.0 | 3.4.1 |
| `bootstrap-sass` | RubyGems | From 3.0.0 | 3.4.1 |
| `twitter-bootstrap-rails` | RubyGems | All versions | 5.3.0 |
| `twitter-bootstrap-rails` | RubyGems | All versions | 5.3.0 |
| `bootstrap-sass` | npm | From 3.0.0 | 3.4.1 |
| `bootstrap-sass` | npm | From 3.0.0 | 3.4.1 |
| `python-XStatic-Bootstrap-SCSS` | Red Hat:openstack:16.1::el8 | All versions | 0:3.4.1.0-2.el8ost |
| `python-XStatic-Bootstrap-SCSS` | Red Hat:openstack:16.2::el8 | All versions | 0:3.4.1.0-2.el8ost |
| `python3-XStatic-Bootstrap-SCSS` | Red Hat:openstack:16.2::el8 | All versions | 0:3.4.1.0-2.el8ost |
| `xstatic-bootstrap-scss-common` | Red Hat:openstack:16.2::el8 | All versions | 0:3.4.1.0-2.el8ost |

Products: F5 Big-Ip Access Policy Manager, F5 Big-Ip Advanced Firewall Manager, F5 Big-Ip Analytics, F5 Big-Ip Application Acceleration Manager, F5 Big-Ip Application Security Manager, F5 Big-Ip Domain Name System, F5 Big-Ip Edge Gateway, F5 Big-Ip Fraud Protection Service, F5 Big-Ip Global Traffic Manager, F5 Big-Ip Link Controller, F5 Big-Ip Local Traffic Manager, F5 Big-Ip Policy Enforcement Manager, F5 Big-Ip Webaccelerator, Getbootstrap Bootstrap, Redhat Virtualization Manager, Tenable Tenable.sc.

## How do I fix CVE-2019-8331?

Upgrade bootstrap to a fixed version for your release line: 3.4.1 or 4.3.1.

## Is CVE-2019-8331 being exploited?

There is no known exploitation of CVE-2019-8331 in the wild and no public exploit code.

Public exploit code:

- A poc for Bootstrap XSS(CVE-2024-6485、CVE-2016-10735、CVE-2019-8331、CVE-2018-14040) (github_poc): https://github.com/Yumeae/Bootstrap-with-XSS
- Vulnearability Report of the New Jersey official site (github_poc): https://github.com/Snorlyd/https-nj.gov---CVE-2019-8331
- ช่องโหว่ CVE-2019-8331 (github_poc): https://github.com/Thampakon/CVE-2019-8331

## Other vulnerabilities in F5 Big-Ip Access Policy Manager

- [CVE-2023-46747](https://insights.sbomify.com/CVE-2023-46747/): F5 BIG-IP Configuration Utility Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-1388](https://insights.sbomify.com/CVE-2022-1388/): F5 BIG-IP Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2021-22986](https://insights.sbomify.com/CVE-2021-22986/): F5 BIG-IP and BIG-IQ Centralized Management iControl REST Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2021-22991](https://insights.sbomify.com/CVE-2021-22991/): F5 BIG-IP Traffic Management Microkernel Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2020-5902](https://insights.sbomify.com/CVE-2020-5902/): F5 BIG-IP Traffic Management User Interface (TMUI) Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8331 and fix it if it is affected.

What it is: CVE-2019-8331 is a medium-severity cross-site scripting vulnerability in F5 Big-Ip Access Policy Manager, published on 20 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-8331 in the wild and no public exploit code.

Affected packages and fixed versions:
- bootstrap (NuGet): affected from 3.0.0; fixed in 3.4.1
- bootstrap (NuGet): affected from 3.0.0; fixed in 3.4.1
- bootstrap (NuGet): affected from 4.0.0; fixed in 4.3.1
- bootstrap (NuGet): affected from 4.0.0; fixed in 4.3.1
- bootstrap (RubyGems): affected all versions; fixed in 4.3.1
- bootstrap (RubyGems): affected all versions; fixed in 4.3.1
- bootstrap (npm): affected from 3.0.0; fixed in 3.4.1
- bootstrap (npm): affected from 3.0.0; fixed in 3.4.1
- bootstrap (npm): affected from 4.0.0; fixed in 4.3.1
- bootstrap (npm): affected from 4.0.0; fixed in 4.3.1
- org.webjars:bootstrap (Maven): affected from 3.0.0; fixed in 3.4.1
- org.webjars:bootstrap (Maven): affected from 3.0.0; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8331/ (Markdown: https://insights.sbomify.com/CVE-2019-8331/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8331
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8331
- OSV: https://osv.dev/vulnerability/CVE-2019-8331

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8331/
Summaries are generated and may contain mistakes; the official description above is the record.
