# CVE-2019-8400: Hydra has Reflected XSS via error_hint parameter

> An attacker can execute arbitrary scripts in a victim's browser via the error_hint parameter in ORY Hydra's OAuth2 fallback error page.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Feb 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7v6r-w4r6-mhch, GO-2026-4861

## What is CVE-2019-8400?

CVE-2019-8400 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ORY Hydra before v1.0.0-rc.3+oryOS.9 has Reflected XSS via the oauth2/fallbacks/error error_hint parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-8400?

3 open source packages ship an affected version, including github.com/ory/hydra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ory/hydra` | Go | All versions | None |
| `github.com/ory/hydra` | Go | All versions | 1.4.8 |
| `github.com/ory/hydra` | Go | All versions | 1.4.8 |

Products: Ory Hydra.

## How do I fix CVE-2019-8400?

Upgrade github.com/ory/hydra to 1.4.8 or later.

## Is CVE-2019-8400 being exploited?

There is no known exploitation of CVE-2019-8400 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-33504](https://insights.sbomify.com/CVE-2026-33504/): Ory Hydra has a SQL injection via forged pagination tokens (high 7.2)
- [CVE-2020-5300](https://insights.sbomify.com/CVE-2020-5300/): Disallow replay of `private_key_jwt` by blacklisting JTIs in Hydra (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8400 and fix it if it is affected.

What it is: CVE-2019-8400 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-8400 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ory/hydra (Go): affected all versions; no fix listed
- github.com/ory/hydra (Go): affected all versions; fixed in 1.4.8
- github.com/ory/hydra (Go): affected all versions; fixed in 1.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8400/ (Markdown: https://insights.sbomify.com/CVE-2019-8400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8400
- OSV: https://osv.dev/vulnerability/CVE-2019-8400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8400/
Summaries are generated and may contain mistakes; the official description above is the record.
