# CVE-2019-8903: Path Traversal in total.js

> Attackers can exploit a path traversal vulnerability in Total.js Platform to read arbitrary files from the server.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3q32-j57w-q4w7

## What is CVE-2019-8903?

CVE-2019-8903 is a high-severity path traversal vulnerability in n/a, published on 18 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

index.js in Total.js Platform before 3.2.3 allows path traversal.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-8903?

2 open source packages ship an affected version, including total.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `total.js` | npm | All versions | 3.2.3 |
| `total.js` | npm | All versions | 3.2.3 |

Products: Totaljs Total.js.

## How do I fix CVE-2019-8903?

Upgrade total.js to 3.2.3 or later.

## Is CVE-2019-8903 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-8903 exists.

Public exploit code:

- Total.js prior to 3.2.4 Directory Traversal (metasploit)
- Totaljs <3.2.3 - Local File Inclusion (nuclei): http/cves/2019/CVE-2019-8903.yaml

## Other vulnerabilities in n/a

- [CVE-2021-23389](https://insights.sbomify.com/CVE-2021-23389/): Arbitrary Code Execution (critical 9.8)
- [CVE-2021-23344](https://insights.sbomify.com/CVE-2021-23344/): Remote Code Execution (RCE) (critical 9.8)
- [CVE-2024-48655](https://insights.sbomify.com/CVE-2024-48655/): Code injection in n/a (high 8.8)
- [CVE-2022-44019](https://insights.sbomify.com/CVE-2022-44019/): Command injection in n/a (high 8.8)
- [CVE-2020-28494](https://insights.sbomify.com/CVE-2020-28494/): Command Injection (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-8903 and fix it if it is affected.

What it is: CVE-2019-8903 is a high-severity path traversal vulnerability in n/a, published on 18 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-8903 exists.

Affected packages and fixed versions:
- total.js (npm): affected all versions; fixed in 3.2.3
- total.js (npm): affected all versions; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-8903/ (Markdown: https://insights.sbomify.com/CVE-2019-8903/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-8903
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-8903
- OSV: https://osv.dev/vulnerability/CVE-2019-8903

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-8903/
Summaries are generated and may contain mistakes; the official description above is the record.
