{"answers":{"affected":"2 open source packages ship an affected version, including laravel/framework.","exploited":"There is no known exploitation of CVE-2019-9081 in the wild and no public exploit code.","fix":"Upgrade laravel/framework to 6.20.44 or later.","what":"CVE-2019-9081 is a vulnerability in laravel/framework, published on 24 Feb 2019."},"fix_prompt":"Check this codebase for CVE-2019-9081 and fix it if it is affected.\n\nWhat it is: CVE-2019-9081 is a vulnerability in laravel/framework, published on 24 Feb 2019. \nExploitation: There is no known exploitation of CVE-2019-9081 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- laravel/framework (Packagist): affected from 5.7.0; fixed in 6.20.44\n- laravel/framework (Packagist): affected from 5.7.0; fixed in 6.20.44\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-9081/ (Markdown: https://insights.sbomify.com/CVE-2019-9081/index.md)","id":"CVE-2019-9081","markdown":"https://insights.sbomify.com/CVE-2019-9081/index.md","name":"CVE-2019-9081","record":{"aliases":["GHSA-pfg4-p438-p874"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: none","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2021-05-17","github_poc":3,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-05-17T06:54:05Z","kind":"github_poc","ref":"https://github.com/nth347/CVE-2019-9081_PoC","stars":1,"title":"PoC for CVE-2019-9081"},{"date":"2021-10-29T14:47:39Z","kind":"github_poc","ref":"https://github.com/scopion/cve-2019-9081","stars":0,"title":null},{"date":"2023-04-25T09:07:39Z","kind":"github_poc","ref":"https://github.com/qafdevsec/CVE-2019-9081_PoC","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Laravel Framework Deserialization Vulnerability","id":"CVE-2019-9081","indexable":false,"kev":null,"kind":"cve_rejected","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2019"},"n_packages":2,"n_references":0,"next":{"headline":"ThinkPHP Remote Code Execution","id":"CVE-2019-9082"},"packages":[{"ecosystem":"Packagist","fixed":["6.20.44"],"introduced":["5.7.0"],"last_affected":[],"package":"laravel/framework","purl":null,"source":"GHSA-pfg4-p438-p874"},{"ecosystem":"Packagist","fixed":["6.20.44"],"introduced":["5.7.0"],"last_affected":[],"package":"laravel/framework","purl":"pkg:composer/laravel/framework","source":"GHSA-pfg4-p438-p874"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2019-9080"},"products":[],"published":"2019-02-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"REJECTED","updated":"2022-08-19","vendors":[]},"summary":null,"url":"https://insights.sbomify.com/CVE-2019-9081/"}