{"answers":{"affected":"2 open source packages ship an affected version, including irisnet-crypto. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-9115 in the wild and no public exploit code.","fix":"Upgrade irisnet-crypto to 1.1.7 or later.","what":"CVE-2019-9115 is a critical vulnerability in n/a, published on 25 Feb 2019."},"fix_prompt":"Check this codebase for CVE-2019-9115 and fix it if it is affected.\n\nWhat it is: CVE-2019-9115 is a critical vulnerability in n/a, published on 25 Feb 2019. \nExploitation: There is no known exploitation of CVE-2019-9115 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- irisnet-crypto (npm): affected all versions; fixed in 1.1.7\n- irisnet-crypto (npm): affected all versions; fixed in 1.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-9115/ (Markdown: https://insights.sbomify.com/CVE-2019-9115/index.md)","id":"CVE-2019-9115","markdown":"https://insights.sbomify.com/CVE-2019-9115/index.md","name":"CVE-2019-9115","record":{"aliases":["GHSA-5fh8-x9xc-hxmc"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"irisnet-crypto","vendor":"irisnet"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"In irisnet-crypto before 1.1.7 for IRISnet, the util/utils.js file allows code execution because of unsafe eval usage.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"irisnet-crypto RCE Vulnerability","id":"CVE-2019-9115","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Other in n/a","id":"CVE-2019-9116"},"packages":[{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"irisnet-crypto","purl":null,"source":"GHSA-5fh8-x9xc-hxmc"},{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"irisnet-crypto","purl":"pkg:npm/irisnet-crypto","source":"GHSA-5fh8-x9xc-hxmc"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2019-9114"},"products":["n/a"],"published":"2019-02-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2019-9115/"}