# CVE-2019-9115: irisnet-crypto RCE Vulnerability


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Feb 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5fh8-x9xc-hxmc

## What is CVE-2019-9115?

CVE-2019-9115 is a critical vulnerability in n/a, published on 25 Feb 2019. 

### Official description

In irisnet-crypto before 1.1.7 for IRISnet, the util/utils.js file allows code execution because of unsafe eval usage.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-9115?

2 open source packages ship an affected version, including irisnet-crypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `irisnet-crypto` | npm | All versions | 1.1.7 |
| `irisnet-crypto` | npm | All versions | 1.1.7 |

Products: Irisnet Irisnet-Crypto.

## How do I fix CVE-2019-9115?

Upgrade irisnet-crypto to 1.1.7 or later.

## Is CVE-2019-9115 being exploited?

There is no known exploitation of CVE-2019-9115 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9115 and fix it if it is affected.

What it is: CVE-2019-9115 is a critical vulnerability in n/a, published on 25 Feb 2019. 
Exploitation: There is no known exploitation of CVE-2019-9115 in the wild and no public exploit code.

Affected packages and fixed versions:
- irisnet-crypto (npm): affected all versions; fixed in 1.1.7
- irisnet-crypto (npm): affected all versions; fixed in 1.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9115/ (Markdown: https://insights.sbomify.com/CVE-2019-9115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9115
- OSV: https://osv.dev/vulnerability/CVE-2019-9115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9115/
Summaries are generated and may contain mistakes; the official description above is the record.
