# CVE-2019-9153: Message Signature Bypass in openpgp

> Attackers can forge signed messages in OpenPGP.js by replacing signatures, compromising message integrity and authenticity.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qwqc-28w3-fww6

## What is CVE-2019-9153?

CVE-2019-9153 is a high-severity vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Verification of a Cryptographic Signature in OpenPGP.js <=4.1.2 allows an attacker to forge signed messages by replacing its signatures with a "standalone" or "timestamp" signature.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2019-9153?

2 open source packages ship an affected version, including openpgp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openpgp` | npm | All versions | 4.2.0 |
| `openpgp` | npm | All versions | 4.2.0 |

Products: Openpgpjs Openpgpjs.

## How do I fix CVE-2019-9153?

Upgrade openpgp to 4.2.0 or later.

## Is CVE-2019-9153 being exploited?

There is no known exploitation of CVE-2019-9153 in the wild and no public exploit code.

Public exploit code:

- investigate vulnerability of opgp-service to message signature bypass (CVE-2019-9153) of openpgp (github_poc): https://github.com/ZenyWay/opgp-service-cve-2019-9153

## Other vulnerabilities in n/a

- [CVE-2019-9154](https://insights.sbomify.com/CVE-2019-9154/): Improper Key Verification in openpgp (high 7.5)
- [CVE-2015-8013](https://insights.sbomify.com/CVE-2015-8013/): OpenPGP 1.2.0 and earlier decrypts arbitrary messages (high 7.5)
- [CVE-2019-9155](https://insights.sbomify.com/CVE-2019-9155/): Invalid Curve Attack in openpgp (medium 5.9)
- [CVE-2023-41037](https://insights.sbomify.com/CVE-2023-41037/): Cleartext Signed Message Signature Spoofing in openpgpjs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9153 and fix it if it is affected.

What it is: CVE-2019-9153 is a high-severity vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9153 in the wild and no public exploit code.

Affected packages and fixed versions:
- openpgp (npm): affected all versions; fixed in 4.2.0
- openpgp (npm): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9153/ (Markdown: https://insights.sbomify.com/CVE-2019-9153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9153
- OSV: https://osv.dev/vulnerability/CVE-2019-9153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9153/
Summaries are generated and may contain mistakes; the official description above is the record.
