CVE-2019-9155 Invalid Curve Attack in openpgp

Medium 5.9 Published Updated

An attacker can recover the victim's ECDH private key by exploiting an invalid curve attack in the OpenPGP.js library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-9155?

CVE-2019-9155 is a medium-severity vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A cryptographic issue in OpenPGP.js <=4.2.0 allows an attacker who is able provide forged messages and gain feedback about whether decryption of these messages succeeded to conduct an invalid curve attack in order to gain the victim's ECDH private key.

Weakness: CWE-327

Which versions are affected by CVE-2019-9155?

2 open source packages ship an affected version, including openpgp. It affects 1 product.

PackageAffectedFixed in
openpgp npmAll versions4.3.0
openpgp npmAll versions4.3.0

Products include Openpgpjs Openpgpjs.

How do I fix CVE-2019-9155?

Upgrade openpgp to 4.3.0 or later.

Is CVE-2019-9155 being exploited?

There is no known exploitation of CVE-2019-9155 in the wild and no public exploit code.

Sources

Also known as GHSA-77jf-fjjf-xcww.

Is CVE-2019-9155 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free