# CVE-2019-9155: Invalid Curve Attack in openpgp

> An attacker can recover the victim's ECDH private key by exploiting an invalid curve attack in the OpenPGP.js library.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-77jf-fjjf-xcww

## What is CVE-2019-9155?

CVE-2019-9155 is a medium-severity vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A cryptographic issue in OpenPGP.js <=4.2.0 allows an attacker who is able provide forged messages and gain feedback about whether decryption of these messages succeeded to conduct an invalid curve attack in order to gain the victim's ECDH private key.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2019-9155?

2 open source packages ship an affected version, including openpgp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openpgp` | npm | All versions | 4.3.0 |
| `openpgp` | npm | All versions | 4.3.0 |

Products: Openpgpjs Openpgpjs.

## How do I fix CVE-2019-9155?

Upgrade openpgp to 4.3.0 or later.

## Is CVE-2019-9155 being exploited?

There is no known exploitation of CVE-2019-9155 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-9153](https://insights.sbomify.com/CVE-2019-9153/): Message Signature Bypass in openpgp (high 7.5)
- [CVE-2019-9154](https://insights.sbomify.com/CVE-2019-9154/): Improper Key Verification in openpgp (high 7.5)
- [CVE-2015-8013](https://insights.sbomify.com/CVE-2015-8013/): OpenPGP 1.2.0 and earlier decrypts arbitrary messages (high 7.5)
- [CVE-2023-41037](https://insights.sbomify.com/CVE-2023-41037/): Cleartext Signed Message Signature Spoofing in openpgpjs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9155 and fix it if it is affected.

What it is: CVE-2019-9155 is a medium-severity vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9155 in the wild and no public exploit code.

Affected packages and fixed versions:
- openpgp (npm): affected all versions; fixed in 4.3.0
- openpgp (npm): affected all versions; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9155/ (Markdown: https://insights.sbomify.com/CVE-2019-9155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9155
- OSV: https://osv.dev/vulnerability/CVE-2019-9155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9155/
Summaries are generated and may contain mistakes; the official description above is the record.
