{"answers":{"affected":"2 open source packages ship an affected version, including studio-42/elfinder. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-9194 exists.","fix":"Upgrade studio-42/elfinder to 2.1.48 or later.","what":"CVE-2019-9194 is a critical command injection vulnerability in n/a, published on 26 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-9194 and fix it if it is affected.\n\nWhat it is: CVE-2019-9194 is a critical command injection vulnerability in n/a, published on 26 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-9194 exists.\n\nAffected packages and fixed versions:\n- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.48\n- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.48\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-9194/ (Markdown: https://insights.sbomify.com/CVE-2019-9194/index.md)","id":"CVE-2019-9194","markdown":"https://insights.sbomify.com/CVE-2019-9194/index.md","name":"CVE-2019-9194","record":{"aliases":["GHSA-4223-qj94-7x9p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"elFinder file manager","requires_auth":"none","summary":"Attackers can execute arbitrary commands via the PHP connector in elFinder, requiring an upgrade to secure the file manager.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"elfinder","vendor":"std42"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"elFinder before 2.1.48 has a command injection vulnerability in the PHP connector.","ecosystems":["Packagist"],"exploits":{"exploitdb":3,"first_seen":"2019-02-26","github_poc":2,"max_poc_stars":2,"metasploit":1,"nuclei":1,"refs":[{"date":"2026-02-18T00:40:24Z","kind":"github_poc","ref":"https://github.com/estebanzarate/CVE-2019-9194-elFinder-Command-Injection-PoC","stars":2,"title":"Command injection vulnerability in elFinder \u003c= 2.1.47 via the PHP connector component. Allows unauthenticated remote code execution as the web server user."},{"date":"2019-02-26","kind":"metasploit","ref":"exploit/unix/webapp/elfinder_php_connector_exiftran_cmd_injection","stars":null,"title":"elFinder PHP Connector exiftran Command Injection"},{"date":"2019-03-04","kind":"exploitdb","ref":"46481","stars":null,"title":"elFinder 2.1.47 - 'PHP connector' Command Injection"},{"date":"2019-03-13","kind":"exploitdb","ref":"46539","stars":null,"title":"elFinder PHP Connector \u003c 2.1.48 - 'exiftran' Command Injection (Metasploit)"},{"date":"2019-03-13","kind":"exploitdb","ref":"46539","stars":null,"title":"elFinder PHP Connector \u003c 2.1.48 - 'exiftran' Command Injection (Metasploit)"},{"date":"2019-03-15T18:16:27Z","kind":"github_poc","ref":"https://github.com/cved-sources/cve-2019-9194","stars":0,"title":"cve-2019-9194"},{"date":null,"kind":"nuclei","ref":"http/cves/2019/CVE-2019-9194.yaml","stars":null,"title":"elFinder \u003c= 2.1.47 - Command Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"elFinder command injection vulnerability in the PHP connector","id":"CVE-2019-9194","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":5,"next":{"headline":"Path traversal in n/a","id":"CVE-2019-9195"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.48"],"introduced":["0"],"last_affected":[],"package":"studio-42/elfinder","purl":null,"source":"GHSA-4223-qj94-7x9p"},{"ecosystem":"Packagist","fixed":["2.1.48"],"introduced":["0"],"last_affected":[],"package":"studio-42/elfinder","purl":"pkg:composer/studio-42/elfinder","source":"GHSA-4223-qj94-7x9p"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2019-9193"},"products":["n/a"],"published":"2019-02-26","related":[{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2023-52044","kev_date_added":null,"published":"2024-10-31"},{"cvss_score":9.8,"headline":"Studio 42 elFinder vulnerable to Incorrect Access Control","id":"CVE-2024-38909","kev_date_added":null,"published":"2024-07-30"},{"cvss_score":9.8,"headline":"RCE in Studio-42 elFinder on Windows before 2.1.61","id":"CVE-2022-27115","kev_date_added":null,"published":"2022-04-11"},{"cvss_score":9.8,"headline":"elFinder Unrestricted File Upload vulnerability","id":"CVE-2021-43421","kev_date_added":null,"published":"2022-04-07"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities leading to RCE","id":"CVE-2021-32682","kev_date_added":null,"published":"2021-06-14"},{"cvss_score":9.1,"headline":"Path Traversal in Studio-42 elFinder through 2.1.60","id":"CVE-2022-26960","kev_date_added":null,"published":"2022-03-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via the PHP connector in elFinder, requiring an upgrade to secure the file manager.","url":"https://insights.sbomify.com/CVE-2019-9194/"}