# CVE-2019-9194: elFinder command injection vulnerability in the PHP connector

> Attackers can execute arbitrary commands via the PHP connector in elFinder, requiring an upgrade to secure the file manager.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4223-qj94-7x9p

## What is CVE-2019-9194?

CVE-2019-9194 is a critical command injection vulnerability in n/a, published on 26 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

elFinder before 2.1.48 has a command injection vulnerability in the PHP connector.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-9194?

2 open source packages ship an affected version, including studio-42/elfinder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `studio-42/elfinder` | Packagist | All versions | 2.1.48 |
| `studio-42/elfinder` | Packagist | All versions | 2.1.48 |

Products: Std42 Elfinder.

## How do I fix CVE-2019-9194?

Upgrade studio-42/elfinder to 2.1.48 or later.

## Is CVE-2019-9194 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-9194 exists.

Public exploit code:

- Command injection vulnerability in elFinder <= 2.1.47 via the PHP connector component. Allows unauthenticated remote code execution as the web server user. (github_poc): https://github.com/estebanzarate/CVE-2019-9194-elFinder-Command-Injection-PoC
- elFinder PHP Connector exiftran Command Injection (metasploit)
- elFinder 2.1.47 - 'PHP connector' Command Injection (exploitdb)
- elFinder PHP Connector < 2.1.48 - 'exiftran' Command Injection (Metasploit) (exploitdb)
- elFinder PHP Connector < 2.1.48 - 'exiftran' Command Injection (Metasploit) (exploitdb)
- cve-2019-9194 (github_poc): https://github.com/cved-sources/cve-2019-9194

## Other vulnerabilities in n/a

- [CVE-2023-52044](https://insights.sbomify.com/CVE-2023-52044/): File upload in n/a (critical 9.8)
- [CVE-2024-38909](https://insights.sbomify.com/CVE-2024-38909/): Studio 42 elFinder vulnerable to Incorrect Access Control (critical 9.8)
- [CVE-2022-27115](https://insights.sbomify.com/CVE-2022-27115/): RCE in Studio-42 elFinder on Windows before 2.1.61 (critical 9.8)
- [CVE-2021-43421](https://insights.sbomify.com/CVE-2021-43421/): elFinder Unrestricted File Upload vulnerability (critical 9.8)
- [CVE-2021-32682](https://insights.sbomify.com/CVE-2021-32682/): Multiple vulnerabilities leading to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9194 and fix it if it is affected.

What it is: CVE-2019-9194 is a critical command injection vulnerability in n/a, published on 26 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-9194 exists.

Affected packages and fixed versions:
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.48
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9194/ (Markdown: https://insights.sbomify.com/CVE-2019-9194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9194
- OSV: https://osv.dev/vulnerability/CVE-2019-9194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9194/
Summaries are generated and may contain mistakes; the official description above is the record.
